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Windows实例内无法使用Internet Explorer浏览器访问外部网站如何处理?

  • 网络连接问题
  • 发布于 2025-04-01
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本文介绍在Windows实例内无法使用Internet Explorer浏览器访问外部网站的问题描述、问题原因和解决方案。

问题描述

在Windows实例内无法使用操作系统自带的Internet Explorer浏览器访问外部网站,提示如下:

问题原因

在Windows实例内无法使用Internet Explorer浏览器访问外部网站,可能是如下原因导致:

  • ECS实例没有配置公网IP地址

  • 本地网络和DNS解析问题

  • 使用的浏览器配置问题

  • IP地址安全策略等网络设置问题

解决方案

您可以通过以下步骤逐步排查,解决上述问题。

说明

以下操作步骤以Windows Server 2019 数据中心版 64位中文版为例,实际操作以您实际的Windows实例操作系统为准。

步骤一:排查ECS实例的公网IP

  1. 查看ECS实例网络信息。

    具体操作,请参见查看实例信息。

    • 如果ECS实例已配置公网IP地址,则您需要继续执行步骤二:排查网络相关设置。

    • 如果ECS实例未配置公网IP地址,则您需要执行下一步。

  2. 选择如下任意一种方法,为ECS实例配置公网IP地址。

    • 方法一:

      申请弹性公网IP并绑定到ECS实例,具体操作,请参见申请EIP和绑定ECS实例。

    • 方法二:

      通过升级公网带宽配置来获取固定公网IP,具体操作,请参见修改固定公网带宽。

    • 方法三:

      通过公网NAT网关访问互联网,具体操作,请参见使用公网NAT网关SNAT功能访问互联网。

步骤二:排查网络相关设置

排查本地网络

  1. 获取本地主机的公网IP地址。

    1. 在桌面左下角,单击搜索图标图标。

    2. 输入cmd,然后在弹出的面板中单击命令提示符。打开2019命令提示符

    3. 在命令提示符中,执行curl cip.cc 命令。

      • 如果回显中获取到本地主机的公网IP信息,如图所示,则本地主机网络正常,无需排查DNS解析问题,继续执行步骤三:排查Internet Explorer浏览器和步骤四:排查IP安全策略等网络限制。本机网络正常

      • 如果回显中无法获取到本地主机的公网IP信息,如图所示,则继续执行下一步,检查本地主机网络配置。本机网络异常-xin

  2. 检查本地主机网络配置。

    1. 在桌面左下角,单击搜索图标图标。

    2. 输入控制面板,然后在弹出的面板中单击控制面板。

    3. 在控制面板中,选择网络和Internet > 网络和共享中心,然后单击以太网。网络和共享中心

    4. 在以太网状态面板中,单击详细信息,然后检查是否已启用DHCP。以太网状态

    5. 在以太网状态面板中,单击属性,然后选择Internet协议版本 4(TCP/IPv4) > 属性并选择自动获得IP地址。勾选自动获得IP地址

排查DNS解析

  1. 远程登录ECS实例。

    具体操作,请参见连接方式概述。

  2. 在桌面左下角,单击搜索图标图标。

  3. 输入cmd,然后在弹出的面板中单击命令提示符。打开2019命令提示符

  4. 在CMD命令提示符中,执行ping 外部网站域名命令,检查DNS解析是否正常。

    以外部网站域名为www.aliyun.com为例,执行ping www.aliyun.com命令。

    • 如果命令回显中,解析出域名对应的IP地址,如图所示,则表示DNS解析正常,您需要继续执行步骤三:排查Internet Explorer浏览器。DNS域名解析正常

    • 如果命令回显中,未解析出域名对应的IP地址,则表示DNS解析异常。此时,您需要执行下一步操作,处理DNS异常。

  5. 处理DNS异常。

    1. 在桌面左下角,单击搜索图标图标。

    2. 输入ncpa.cpl,然后在弹出的面板中单击ncpa.cpl。

    3. 在网络连接页面,右键单击对应的网卡,然后单击属性。网络连接

    4. 在以太网属性页面,双击Internet协议版本 4(TCP/IPv4)。以太网属性

    5. 选择使用下面的DNS服务器地址,并将阿里云公共DNS地址223.5.5.5和223.6.6.6分别填入首选DNS服务器和备用DNS服务器中。

      说明

      您也可以填写其他公共DNS服务器的IP地址。

      填入DNS地址

    6. 单击确定,然后依次关闭配置窗口。

  6. 再次使用Internet Explorer浏览器访问外部网站。

    • 如果正常访问外部网站,则表示该问题已解决。

    • 如果仍然不能访问外部网站,则您需要继续执行步骤三:排查Internet Explorer浏览器。

步骤三:排查Internet Explorer浏览器

如果DNS解析正常但是使用系统自带的Internet Explorer浏览器还是无法访问网站,可能是由于Internet Explorer浏览器配置或者兼容性等问题导致的,您可以尝试使用Chrome、Firefox或其他浏览器做访问对比测试。如果使用其他浏览器均可以正常访问网站,则需要通过重置Internet Explorer浏览器等方式来修复Internet Explorer浏览器。

重置Internet Explorer浏览器的操作步骤如下:

  1. 远程登录ECS实例。

    具体操作,请参见连接方式概述。

  2. 打开Internet Explorer浏览器。

  3. 在Internet Explorer浏览器的右上角,单击IE设置按钮图标,然后单击Internet 选项。

  4. 单击高级页签,然后单击重置。重置IE

  5. 在提示框中,单击重置。

步骤四:排查IP安全策略等网络限制

如果经过上述步骤排查后,仍然无法访问网站。则您需检查Windows操作系统上是否配置了该外部网站相关的IP安全策略或者其他第三方网络管理软件,阻断了DNS解析或者对该外部网站相关的访问添加了限制,操作步骤如下:

  1. 远程登录ECS实例。

    具体操作,请参见连接方式概述。

  2. 在桌面左下角,单击搜索图标图标。

  3. 输入secpol.msc,然后在弹出的面板中单击secpol.msc。

  4. 在本地安全策略页面,单击IP安全策略,在本地计算机,检查是否配置并指派了安全策略。 如果存在相关的IP安全策略,则需要暂停指派该策略。指派策略

  5. 再次使用Internet Explorer浏览器访问外部网站。

    • 如果正常访问外部网站,则表示该问题已解决。

    • 如果仍然不能访问外部网站,则执行如下操作:

      1. 检查是否存在其他网络安全相关的软件设置了拦截或限制。如果存在,则解除限制后,重新访问该网站。

      2. 检查Windows实例内的Time_Wait连接是否已释放,如果未释放则会导致访问外部网站失败,则您需要继续处理该问题,具体操作,请参见Windows系统的ECS实例Time_Wait连接不释放导致访问外网失败。

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